Archives de catégorie : astuces

catalina et max…

Si vous passez en Mac OS 10.15 Catalina, une nouvelle sécurité empêche le chargement des externals qui sont « non-signés », comme est actuellement le cas de beaucoup de packages comme spat ou miller puckette. Voici un article qui parle de la solution sur le site de cycling 74. Il s’agit d’une manip avec le « terminal »…

Voici le lien, ou bien voir plus bas.

https://cycling74.com/articles/using-unsigned-max-externals-on-mac-os-10-15-catalina


Using Unsigned Max Externals on Mac OS 10.15 (Catalina)

The release of Mac OS 10.15 (aka Catalina) has brought increased security settings that may prevent the loading of unsigned 3rd party externals. On Mac OS 10.15, when a file like this is downloaded from the web, it is marked with com.apple.quarantine via extended file attributes (xattrs), which then prevents loading in Max. The longer term solution will be for third party developers to sign their externals, however there are many safe-to-use externals that are no longer in active development, but still relied on by many. In the meantime, there are several workarounds that can be used. All of these options involve bypassing Apple’s security infrastructure, so make sure you have downloaded the externals from a trusted source.

The current best option is to run Terminal’s ‘xattr’ utility using the ‘-d’ option to remove the ‘com.apple.quarantine’ xattr entirely. Open the Terminal utility and type: xattr -d com.apple.quarantine [path/to/extern.mxo]

If you have a number of externals that you wish to perform this on, you can use the ‘-r’ option to the xattr command, which acts recursively on a directory or bundle. Open the Terminal utility and type: xattr -d -r com.apple.quarantine [path/to/extern/directory]

In an upcoming version of Max, we hope to add better notification when the com.apple.quarantine xattr is present on a file that Max attempts to load, and will be exploring other options for improvements in this area.

Please note that the « right-click » to overcome Gatekeeper no longer appears to work on 10.15+.